HomeProductsDownloadsPurchaseSupportContact
 

Phantom Cine AMA for Avid v2.0

Binary installer for “Phantom Cine AMA for Avid v2.0”:
(Runs in demo mode until license is purchased.)

Phantom Cine AMA for Avid v2.0 User Manual

This software is compatible with both macOS and Windows.

  macOS 10.11.5 or later
PhantomCineAMA-Mac-2.0.3031.dmg


  Windows 10 (64-bit)
PhantomCineAMA-Win64-2.0.3031.zip



Macintosh System Requirements:
- Avid Media Composer 2018 or later
- macOS 10.11.5 or later,
- A Mac system that meets Avid's minimum requirements,
- NVidia or AMD Graphics with OpenCL Support.


Windows System Requirements:

- Avid Media Composer 2018 or later.
- Windows 10 (64-bit) or later
- A Windows 10 PC system that meets Avid's minimum requirements
- NVidia or AMD Graphics with OpenCL Support.


© 2004-2021 Glue Tools, LLC LLC.