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System Requirements
Minimum Hardware and Software Configuration
• Intel Macintosh
• Mac OS X 10.7.5
• QuickTime 7.6.6 (or later)
• 1280 x 1024 display
• Final Cut Pro 7 and Compressor 3.5 
Recommended Hardware and Software Configuration
• 8-Core Mac Pro
• MacOSX 10.7.5 or MacOSX 10.8.2 (or later)
• QuickTime 7.6.6 (or later)
• Dual 1920 x 1200 displays
• Thunderbolt, SAS, SATA or Fiber-Channel RAID or SAN
• Final Cut Pro 7 and Compressor 3.5
• or Compressor 4
Playback Requirements:
Cineon and DPX Images are uncompressed. As a result, film resolution Cineon and DPX files are 
roughly 12.5 Megabytes (2048x1556). High Def resolution Cineon or DPX images (1920x1080) 
are typically less than 8.5 Megabytes. Sequences that run at 24 FPS will need a considerable 
amount of bandwidth for real time playback. You will want to make sure that you have a 
machine that is up to the task. With the lower costs of high speed storage, it is really 
recommended that a RAID of some sort is used.

Supported DPX Payload Types:
Unlike the Cineon file format, DPX can support several different types of “payloads.” Here is a 
list of the currently supported image encodings:

DPX Import:
• 16-bit RGB
• 16-bit RGBA
• 10-bit RGB
• 10-bit RGBA
• 8-bit RGB
• 8-bit RGBA
• 10-bit Alpha
• 8-bit Alpha
• 1-bit Alpha
• 10-bit 422 YCbCr
• 8-bit 422 YCbCr

DPX Export:
• 10-bit RGB
• 10-bit RGBA
• 16-bit RGB
• 16-bit RGBA
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Overview
The Cineon/DPX Toolkit for MacOSX package is a collection of plugins and small utilities. These 
tools turn your editing package into a powerful online editing solution. Throughout this guide, 
you will be introduced to each of these components, and see how they individually work.

QuickTime Components
The Cineon and DPX QuickTime Components perform all of the imaging, playback, metadata, 
importing and exporting functions of the package. This is the heart of the software package. All 
applications that use Apple’s QuickTime can access all aspects of the Cineon and DPX files. 
Applications ranging from Final Cut Pro, Adobe AfterEffects, and Motion can read and write 
these digital film file formats.

There are no direct “controls” or programs to launch and run in order to use these components. 
Simply single-clicking on a Cineon or DPX frame in Finder, allows you to see a thumbnail of the 
image.

System Preferences
The Cineon/DPX Preference Pane is where you pre-set all of the settings that the components 
use. These settings include LOG/LIN conversions, Alpha Channel activation, Licensing 
information, Time Code support, etc.

Final Cut Pro 7 Plugins
With a purchased license, you will see the Final Cut Pro 7 plugins in the 
File->Import menu. They will be labeled: “Glue Tools Cineon Sequence Import” and “Glue Tools 
DPX Sequence Import.” You will select either of these to import a Cineon or DPX sequence into 
Final Cut Pro 7 as if it were a regular QuickTime movie clip. Shift Selecting folders containing a 
number of Cineon or DPX sequences, will let you load a number of clips at once.

Compressor Plugins
A new feature of this software is full support for Compressor 3.5 or Compressor 4. Included is a 
set of Compressor Encoder plugins. Compressor can now receive sequences from Final Cut Pro 
and process them. This is a much better solution when dealing with a significant amount of 
footage. Shots can be queued and Compressor can work its way through them. If you have 
multiple systems, you can even have the jobs distributed amongst the machines to speed up 
the rendering process.

Spotlight and QuickLook Plugins
The Spotlight and QuickLook Plugins enable your system to see inside the Cineon and DPX 
frames. Finder can extract specific information from the Cineon or DPX files when it does a “Get 
Info.” You can search for Time Code numbers, reel names, or encoding characteristics from the 
Finder’s Spotlight panel. Simple shell scripts can also take advantage of the spotlight services 
and sift through frames for specific data. You will also be able to view thumbnails through all of 
you applications as well.
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MacOSX 10.7.5 and 10.8.x Compatibility with Cineon/DPX Toolkit
By default, QuickTime Pro 7 is not installed with MacOSX 10.7 or 10.8. QuickTime Pro 7 is 
required before it can be used on these systems. While this installer is provided on the MacOSX 
10.6 Snow Leopard Installation DVD, Apple does not provide this installer with later versions of 
the OS. Fortunately, this installer is available from Apple’s website. The download link is: 
http://support.apple.com/kb/dl923

Once you have downloaded and installed QuickTime Pro 7, you can proceed with any of our 
packages. Be sure to use QuickTime Player 7 in the /Applications/Support folder to view your 
Cineon or DPX sequences.
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Installation and Demo Mode
Installation
Installation is as simple as double-clicking on the installer package, then selecting the hard 
disk that you want to install the software onto. Once installed, you will need to reboot your 
machine.

Note: If the system does not contain the proper version of Final Cut Studio, various parts of the 
Cineon/DPX Toolkit will not install. If after the installation, parts of this product do not show 
up, please double-check that you meet the  minimum requirements.

IMPORTANT - Demo Mode

By default, the software will be placed into “Demo Mode.” If no license is purchased, the Cineon 
and DPX Images with be drawn or exported with a large colored bar through the center of the 
image. Once a license has been purchased, the time limit will be removed and all of the imagery 
will be rendered properly. Another limitation is with Time Code. Time Code will be forced to 
09:09:09:00 for every sequence. When importing footage into Final Cut Pro 7, the Sequences 
will be identified with the same name.

To remove these limitations, a license must be purchased. Otherwise most of the software’s 
functionality will be available for testing and evaluation.
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Licensing
License Activation
Licensing must be done while connected to the Internet. If you do not have an internet 
connection, you will not be able to activate the license. In many cases any type of network 
connection will get you up and running. Once activated, you will not be required to have a 
network connection, unless you want to move the license to another Macintosh.

To activate the license, you will need the Registration Code that was emailed to you. Open the 
System Preferences, and click on the CineonDPX preference pane. You will see a “Lock” icon on 
the lower left side of the panel. Click on this, to authorize yourself to apply the license.

Once unlocked, click on the “Activate” button which will then open the panel for the 
Registration Code. You can then cut and paste the encryption string from the email, into the 
“Activation Code:” field. Once you click on the “Activate” button, the software will verify the 
license with our server and create a permanent license for you. Until you decide to move the 
license, this will be the only time that the internet is used for licensing.

Revoking/De-authorizing a License

If you need to move a license to another machine, you can use the same license code to 
“Revoke” the license from the machine that you are on. Just as you had done with the license 
activation, Open the System Preferences->CineonDPX preference pane. Open the Info tab and 
and authorize the license controls. Click on the “Revoke” button. You can now cut and paste the 
same activation code into the “Activation Code:” field. Then click on the “Revoke” button. Once 
deactivated, the license will be free so that another machine can be used.

License Troubleshooting
If you encounter a problem with your licensing because of network issues, consult with your IT 
Dept. The most common cause of problems is a blocked internet port or a Firewall Proxy 
system. The licensing can be modified to use one of 2 internet ports: Port 80, which is the 
default port or Port 44333 (an alternate port). Select either of these ports to try to perform a 
license authorization. 

If the problem persists, email support@gluetools.com for further assistance, or, go to http://
support.gluetools.com and take a look through our Knowledgebase. The knowledgebase has 
the most up to date information on licensing help.
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Quick Start Guide
Importing a Cineon or DPX Image Sequence - The Correct Way
Just about everyone has used QuickTime to load a range of individual frames and convert them 
into a single movie. Normally, this is done by using an “Import Image Sequence” command 
inside the QuickTime application. Typically these images are a series of TIFF files or JPEGs with 
sequential frame numbers. Under normal circumstances, this works just fine. The sequences of 
picture files are just what they are . . . a series of still images with no other useful data.

However, this is not true for Cineon and DPX files. The Cineon and DPX sequences are in fact a 
single movie. The difference between a Cineon or DPX “Movie” and a regular “.mov” file, is that 
each frame is a separate file.  A “.mov” file has all of its frames inside a single file. A feature 
that makes Cineon or DPX frames different from other Image formats, is that the Cineon and 
DPX frames contain “metadata” that is specific to the film and HD broadcast industry. Time 
Code, slate information, colorimetric information etc, is stored in the image header.

So, what does this ultimately mean? It means that to properly load a Cineon or DPX sequence 
into you favorite application, use the “Open->File...” menu, and select A SINGLE frame from 
your sequence, and then click on “Load” or “Ok.” The entire movie will load shortly. DO NOT use 
“Import Image Sequence” to load the frames.

Glue Tools has custom technology to treat these image types as a “virtual movie file” rather 
than a set of individual image files. This means that all of the frames in the sequence are really 
just a single “Movie.” It also means that when you are selecting any one Cineon or DPX file from 
a sequence, it is the same as opening all of the frames in the sequence. 

Because of this, you no longer need to shift-select all of the frames to load them. As a result of 
the way this works, you are able to load metadata, Time Code and other information that would 
normally be associated with a QuickTime movie.

But what about the “Import Image Sequence” menu command?

Using this method of loading frames, you loose the ability to import metadata, Time Code, etc. 
You also loose the Playback ability, too. When importing Cineon or DPX frames as an Image 
Sequence, QuickTime believes the sequence is just a bunch of still images, not a series of 
frames in a movie.

If you still aren’t clear on the difference, drop a note in the Glue Tools support forum. More 
examples can be posted. (http://www.gluetools.com/support.html)

Importing a Sequence into QuickTime Player
One of the most basic ways of using the Cineon/DPX Toolkit is to take one of the frames from 
your sequence, drag it over top of the QuickTime icon, and let go. Doing this will open the 
entire sequence inside QuickTime Player. It is as simple as that.

Exporting a Sequence from QuickTime Player
Exporting Cineon or DPX frames are just as easy as importing. Open a movie file that you want 
to convert to a DPX sequence, and then select “File->Export...” from the menu.

Next, change the “Export” Pop-up menu to read “Movie to DPX Image Sequence.” After that, you 
can click on the “Save” button to start saving a range of frames. 

If you wish to alter the export a bit, (i.e.. you need to change the start frame number to 0020 
instead of 0001), you can click on the “Options” button to customize the export.
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Importing a Sequence into Final Cut Pro 7
Final Cut Pro 7 has a specially built interface to work with CIneon and DPX frames. To import 
the frames, select the “File->Import->Glue Tools Cineon Sequence Import...” (or for DPX 
frames, “File->Import->Glue Tools DPX Sequence Import...”). Locate your sequence, click on a 
single frame, and click “Ok.” Your sequence will now appear in the browser, complete with the 
file’s metadata.

That’s it!

You can now drag the sequence onto the timeline to edit.

Exporting a Sequence from Final Cut Pro
Exporting is now handled by Compressor. Refer to the Compressor section of this manual, to 
learn to how create a settings preset and export your frames.

Exporting a Cineon or DPX Sequence from Final Cut Pro 7 is fairly easy. In the browser, you can 
either click on a single clip or the entire sequence. Then, right-click (or control-click) and select 
“Export->Using Compressor...” This will open Compressor, and allow you to create a new 
sequence of Cineon or DPX frames.
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Cineon/DPX Reference
This Package consists of several parts that make up the whole. The Cineon and DPX 
Components themselves, a System Preferences Pane, Spotlight Plugins, and set of Plugins for 
Final Cut Studio. Each of these pieces are briefly described in turn.

Preference Pane
The Cineon/DPX Preferences Pane is where you can change the settings used 
by Cineon and DPX QuickTime Components. If you want of change the LOG/
LIN settings, use a 3D LUT, or override the frame numbering, you can do it in 
the System Preferences. 

Let’s begin by opening the System Preferences, and clicking on the 
CineonDPX preference pane icon.

Once opened you will be presented with a series of tabs, dividing the controls up into a couple 
of different categorize.

DPX Import Tab
You will notice that the DPX Import Tab is divided into three sections. A “DPX Film Import 
Settings” section, “DPX Video Import Settings” section, and “DPX Time Code Settings” sections.

DPX Film/RGB Import Settings:

Conversion
This pop-up menu is used to select your 
conversion method. You can leave it on 
Automatic, which uses the built-in defaults, 
and Cineon or DPX headers to figure out 
how to display the image. Sometimes, 
however, you may need to change these 
settings. Some of the settings include 
“Automatic to QuickTime Video,” “Pass Through (do nothing)” and “LogC to QuickTime Video.” 
These settings will allow you to override the defaults and display the image the way you want.

Cineon Log (LogC) Settings - (NGamma, Display Gamma, White Point, and Black Point)
These text fields are where you enter your Cineon Log (LogC) conversion parameters. These 
parameters can radically change the way your image appears on the screen. While it is fun to 
play with the values to see what effects you can get, you will want to use established settings to 
see how your image would look on your target screen. (i.e.: movie big screen, or High Def 
monitor.)

Note: The Cineon Log (LogC) defaults that are provided are just arbitrary settings. You will really want 
to consult with your DP or film IO house to get the correct settings.
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Aspect Ratio
This pop-up menu allows you to choose 
between a number of different Aspect Ratios, 
that the image will be displayed as. 

For example, when loading the images, you 
can select the 2.35 Aspect Ratio, and the 
images will be automatically re-sized, without 
any data loss. The example image of the 
dinosaur illustrates the concept. The DPX 
frame is an Anamorphic image, and the left is 
an uncorrected 1.778, while the right image 
has been corrected for 2.35.

DPX Playback / Time Code / Metadata Settings:

Frame Rate
This lets you override the frame rate found 
inside the DPX files, and forces your 
application to use the value that you choose. 

TC Frame Rate
This lets you override the time scale that the 
Time Code track uses. This can be different 
from the Real Frame Rate. This control, combined with the Real Frame Rate pop-up can let you 
simulate a Telecine operation. i.e.: selecting a 24 FPS for the Real Frame Rate and a 25 (or 
29.97) for the Time Code. 

TC/Reel Name
By default, if the DPX frames contain a valid Time Code entry, a track is created. The controls 
affect the way the track is seen and identified. The “TC Source Labeling” Pop-up menu 
determines how QuickTime identifies the Time Code track. “User Defined” allows you to type 
your own description into the text field below. When selected, you are able to type in up to 12 
characters, which will be used as the Reel Name. You can also select from different fields in the 
DPX header itself. By selecting either the SMPTE User Bits, Project ID or Image Desc, you can 
grab the raw data and use that, as the Reel Name. If there is no usable data in the header, you 
can now use either the “Root” file name from the first frame, or you can use the parent directory 
that the frames are stored in, as the reel name. 

Another feature is available if the frames came from S.two or Codex Digital Hardware. These 
products create DPX frames with a set detailed metadata. You can select either product, which 
will in turn extract the appropriate Reel (or Roll) Name from the DPX header.

Time Code from Frame Number
This check box enables the Cineon or DPX QuickTime Components to use a Sequence’s frame 
numbers as the Time Code source, rather than the Time Code that is embedded inside the 
header. In the Case of Cineon files, this provides a way to allow you to apply a Time Code track 
to a Cineon sequence. Cineon doesn’t not provide a way to embed Time Code information into 
its header.
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DPX Export Tab
This tab controls the output characteristics for DPX files. From here you can control the way the 
DPX images look, and what information is contained inside the files.

DPX Film Export Settings:

Conversion
This pop-up menu is similar to the Import 
Popup menu. It allows you to select the 
type of export color space conversion. This 
panel doesn’t have an “automatic” setting, 
however. 

Some as well as setting the conversion 
type, you can choose the bit depth of the file that will be created. For instance, you can select 
on of the 10-bit options, or one of the new 16-bit options as well.

Alpha Channel
This pop-up menu allows you to instruct the export component to save an Alpha Channel along 
with the rest of the image data.

Cineon Log (LogC) Settings - (NGamma, Display Gamma, White Point, and Black Point) 
These text fields are where you enter your Cineon Log (LogC) conversion parameters. These 
parameters can radically change the way your image appears when exported. While it is fun to 
play with the values to see what effects you can get, you will want to use established settings to 
see how your image would look on your target screen. (i.e.: Film-out, or High Def Tape.)

Frame Digit Pad
This popup menu lets you select how many digits are to be used in your frame’s filename. 
Selecting “6” for instance, sets your file name to have a 6 digit range in the frame number part 
of the file name. i.e.: my_image.000001.dpx

Start Frame #
This text field lets you type in the starting frame number that you want to use. The default is 
set to use frame 1.

Frame Rate
This popup menu lets you override the default frame rate of the source movie. When set to 
“Auto” the source movie’s frame rate is used as the default playback speed. Choosing a speed 
from the pop-up menu overrides the source playback speed. 
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DPX Header Export Settings:

Image Desc & Project Info
Each text field can hold up to 200 characters 
of information. Ideally, one of these fields 
can be used for shot identification, and the 
other, readable notes about the shot. 
Following such a convention would allow you 
to use your “shot id” to act as the Time Code label, and the other field, to be text about the 
shot, when read back by other applications. (See DPX Time Code settings in the Import Tab.)
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Cineon Tab
This tab contains all of the settings, specific to the Cineon QuickTime components.

Cineon Film Import Settings:

Conversion
This pop-up menu is used to select your 
conversion method. You select from 
“Cineon Log to QuickTime Video,” “Pass 
Through (do nothing)” and “Linear to 
QuickTime Video.” These settings will allow 
you to override the defaults, and display the 
image the way you want. As Cineon is a 
film-only format, you should leave it set to “Cineon Log to QuickTime Video.”

NGamma, Display Gamma, White Point, and Black Point 
These text fields are where you enter your Cineon Log (LogC) conversion parameters. These 
parameters can radically change the way your image appears on the screen. While it is fun to 
play with the values to see what effects you can get, you will want to use established settings to 
see how your image would look on your target screen. (i.e.: movie big screen, or High Def 
monitor.)

Aspect Ratio
This pop-up menu allows you to choose 
between a number of different Aspect Ratios 
that the image will be displayed as. When 
loading the images, you can select the 2.37 
Aspect Ratio, and the images will be 
automatically re-sized, without any data loss. 
The example image of the dinosaur illustrates 
the concept. The DPX frame is an Anamorphic 
Image, and the left is an uncorrected 1.778, 
while the right image has been corrected for 
2.37.

Frame Rate
This lets you override the frame rate that your Cineon frame specifies. Your application will then 
use frame rate that you select.

Cineon Film Export Settings:

Conversion
This pop-up menu is similar to the Import Popup. It allows you to select the type of export 
color space conversion. “QuickTime to 10-bit LogC” is the default when exporting, with the 
option to do a “QuickTime to 10-bit Pass Through” or a “QuickTime to 10-bit Linear” export.
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NGamma, Display Gamma, White Point, and Black Point 
These text fields are where you enter your Cineon Log (LogC) conversion parameters. These 
parameters can radically change the way your image appears when exported. While it is fun to 
play with the values to see what effects you can get, you will want to use established settings to 
see how your image would look on your target screen. (IE; Film-out, or High Def Tape.)

Frame Digit Pad
This popup menu lets you select how many digits are to be used in your frame’s filename. 
Selecting “6” for instance, sets your file name to have a 6 digit range in the frame number part 
of the file name. i.e.: my_image.000001.cin

Start Frame #
This text field lets you type in the starting frame number that you want to use. The default is 
set to use frame 1.

Frame Rate
This lets you override the frame rate that your application has specified. When set to “Auto” the 
application’s frame rate is used as the default playback speed. Choosing a speed from the pop-
up menu overrides the overrides the frame rate that will be inserted into the Cineon file.

Image Desc & Project Info
Each text field can hold up to 200 characters of information. Ideally, one of these fields can be 
used for shot identification, or used as human readable notes about the shot. These fields also 
would allow you to use your “shot id” to act as a Time Code “Reel Name” in Final Cut Pro, even 
though the Cineon format doesn’t support Time Code.
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Codec Settings
The Codec settings tab contains settings that affect the behavior of both the Cineon and DPX 
components.

YCbCr Import & Export Coefficient:
By clicking on the “Import” or “Export” popup 
menus, you can force the use of specific 
YCbCr coefficients. These coefficients 
determine how YCbCr pixels are converted, to 
and from RGB pixels. While QuickTime does a 
reasonable job at determining which coefficients 
should be used, sometimes the application misses that information, and use a “default” that is 
wrong. Here, you can force QuickTime to use what you specify, correcting the problem.

Component Settings Options
This panel has two options to change the 
behavior of the export components. The first 
option “Export Frame Number separator” lets 
you specify a period “.” or an underscore “_” 
character to separate the root part of the 
filename from the frame numbers.

The second option “DPX Export File Endianness” lets you force the DPX file’s endianness to be 
either Big Endian or Little Endian. When in Automatic mode, the native endianness of the source 
machine is used (Typically Little Endian with Intel based Macintosh systems).

Interlace Field Settings

This section lets you set the flag for the interlace mode of you Cineon or DPX sequence. By 
default, the QuickTime interlace flag is set to “Progressive Scan.” This should be fine in every 
case. However, in some cases, you need to change this. 3D tools and plugins often need the 
interlace flag to be set, in order to work. You can change this here, to accommodate those 
packages.

Rendering Mode

This section lets you choose between the default “Intel CPU” rendering engine, vs. using a 
Graphics Card, if supported. Not all graphics cards can be used. You will need to refer to the 
http://support.gluetools.com website to see a complete list of supported GPUs.

InfoTab

In the “Info” tab, you can click on links to the Glue Tools website, as well as direct links to the 
Support/FAQ pages, and the Registration pages. If you wish to purchase a license for the 
Cineon/DPX Toolkit, visit www.gluetools.com, go to the “purchase” page and follow the 
instructions there. 
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QuickTime Export Options
Any QuickTime aware application can easily export Cineon or DPX frames. When you want to 
convert your movie to a sequence of frames, you will want to choose the “Export QuickTime 
Movie” feature of your application. This will be different for each application. For instance, 
QuickTime Player and Final Cut Pro uses “File->Export...,” other apps may use another menu 
item.

We’ll use QuickTime Player to export a sequence of DPX frames, for this example.

Open a movie with QuickTime Player. This can be any kind of movie. You can even use a range 
of Cineon or DPX frames. (This is ideal for converting Cineon to DPX frames, if you want.) We 
will use this as the source movie. Choose “File->Export...” from the QuickTime Player menu. 
Once the “Export” panel is open, create a folder to save the files into, and give the files a name. 
Lets use “test” for now.

Click on the “Export:” Pop-up menu to select the 
“Movie to DPX Image Sequence” (or “Movie to Cineon 
Image Sequence”) export mode. If you need to change 
some settings for this particular export job, you can 
click on the “Options” button to alter the way Cineon 
or DPX frames are saved. But for now, just click on 
“Save” to create a sequence of frame.

That is all there is to it! From the Finder, you can open 
up the folder where the new frames are, and check 
them out. You can even click on a frame, select 
“Command-I” and perform a “Get Info” to see how the 
file was formatted.
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Cineon Export Panel
Continuing with the example, above, open the source movie once again. Before saving, click on 
the “Options” button to open the Cineon Export Options Panel. Briefly, here is a description of 
the features.

Sequence Settings
Start Frame # allows you to adjust the starting frame 
number that files will use.

Frame Number Pad sets the number of digits used in 
the frame numbering. The default is 4 digits. (i.e: 
myframe.0001.dpx). You can set the pad to be up to 7 
digits in size. (myframe.0000001.dpx)

Frame Rate allows you to override the frame rate that 
will be saved into the Cineon (or DPX) header.

Cineon Header Settings
The Image Description and Project Info Text Fields, allows you type up to 100 characters that 
will be embedded into the Cineon or DPX frames. These fields can be indexed and searched by 
Spotlight.

Cineon Codec Color Space Panel
Color space settings for the Cineon Codec are accessed by clicking on the “Color” button in the 
“Cineon Movie Export Settings” panel.

Cineon Color Space Settings
These controls work the same way as the controls in 
the System Preferences. The conversion pop-up menu 
allows you choose between the different export 
options. (QuickTime to 10-bit LogC, etc.) The 
NGamma, Display Gamma, White and Black controls 
are also available as expected. Also, you can force the 
YCbCr Coefficients for YCbCr to RGB conversion, if the 
automatic detection doesn’t work.
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DPX Export Panel
The DPX Export Panel is very similar to the Cineon Panel but has additional features that work 
with Time Code. 

Override Time Code & Start Time
By clicking on the “Override Time Code” button, 
you can specify your own start time. Time Code 
override only supports non-drop frame (NDF) 
values, and must be typed in using the “hours : 
minutes : seconds:  frames” format. Frame 
numbers, and negative values are currently not 
supported.

Keep in mind that the frame rate determines 
how the Time Code should entered. If the frame 
rate is set to 24, then the frame rate should be 
set accordingly. 

Start Frame from Time Code
Also included is a check box that lets you set the frame number in the file name, to match the 
numerical frame count as the Time Code. So, turning this feature on, not only saves the Time 
Code into the DPX header, but also starts the frame number at the same start start time. 

For example, if your start time is 00:00:01:00 at 24 FPS, the start time would be 
myframe.0000024.dpx 
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Final Cut Pro 7 Plugins
Final Cut Pro 7 users can import Cineon or DPX 
sequences with the Import Panels. These panels can 
easily be accessed by selecting the “File->Import...” 
menu. In this menu you will see two items, “Glue Tools 
Cineon Sequence Import...” and “Glue Tools DPX 
Sequence Import...”

The Cineon and DPX Panels are largely identical, with 
the exception of Metadata and Time Code related 
features. 

Also included is an FxPlug Filter which will allow you to 
add a 3DLUT to any of your clips. This works 
specifically inside Final Cut Pro and allows you to 
attach a 3DLUT on a clip by clip basis.

Cineon and DPX Sequence Import Panels
The Cineon and DPX Sequence Import panels for Final Cut Pro 7 provide most of the same 
controls that the Cineon/DPX Preference Pane does. However, the panel adds the ability to 
extract metadata right out of the Cineon and DPX frames, and place the information right into 
your FCP project. Shot notes, color information, and other information is extracted and 
available in the XML that FCP generates.

To import a sequence, all that is needed is to select ONE frame from the sequence in order to 
load the entire shot. Once imported, the extracted metadata from the sequence is placed into 
Final Cut Pro’s XML system.

Cineon and DPX Sequence Presets
Final Cut Pro 7 provides a set of “Sequence Presets” which allows you to quickly configure your 
system for different editing scenarios. Included with the package is a set of Cineon and DPX 
Sequence presets. These are generic presets for standard frame rates, and image sizes. As with 
the other Sequence Presets that Apple provides, you can duplicate and customize these to suit 
your needs.

3DLUT FxPlug Filter
Final Cut Pro and Motion provides developers with a plugin technology for manipulating your 
image. We have developed plugins to let you attach a 3DLUT to your footage. We support a 
couple of different 3DLUT formats. Please refer to the 3DLUT Appendix at the end of this 
document for more information on the LUT file specific.

To get started, import any clip into Final Cut Pro 7. This can be a DPX sequence or any type of 
MOV file that you have on hand. 

Drag your clip onto the timeline and double click on it. Then select the “Filter” tab from the top 
of the Browser:Slug window. You will be presented with a list of sliders and pop-up menus. A 
description of each control is provided below. The best way to learn what they do, is to try them 
out. As you make each adjustment, you can see its effect on the right side of the display.
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A feature of these plugins is that you can duplicate the clip on the timeline several times. If you 
had three copies of the same clip on the timeline, each of the three could have a different 
3DLUT attached. This ideally suits Final Cut Pro for the creative color process.

The plugin provides a single setting:

3DLUT File
- This control is used to specify the 3DLUT file that you wish to use. Click on the “Choose” 
button to open an Open File panel.

These settings are stored inside the Final Cut Pro 7 project file. Nothing that you adjust here 
will affect the file that the 3DLUT is attached to. The changes are non-destructive.
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Compressor Encoder Plugins
The Cineon/DPX Toolkit will install Compressor Encoder Plugins for either Compressor 3.5 
(Included with Final Cut Studio 3) or Compressor 4 which can be downloaded directly from 
Apple’s App Store.

Creating a Cineon/DPX Encoder Setting
When you first open Compressor, a “Settings” 
window is displayed as a part of the group of 
windows that are opened. What you’ll want to 
do is to create a “DPX” custom encoder setting. 
This setting will let you export DPX frames. 
Click on the “Plus sign” button, to open up a 
menu. In this menu, you will see a list of 
encoders. Choose the “Glue Tools DPX 
Encoder” menu item.

Setting up a Cineon/DPX Encoder
Once the DPX Encoder setting is selected from the menu, it will create a settings entry in the 
“Custom” folder in the Settings Window. You can click on it to see its defaults. You will probably 
want to change these defaults, so the encoder exports the DPX frames the way that you need 
them. 

To get to the settings, go to the “Inspector Window,” and click 
on the “Encoder” button (circled in red). This will show you the 
current settings of the DPX Encoder. Click on the “Options” 
button, to open the encoder’s settings window.

You will be presented with a new panel, which resembles the 
the settings available in the System Preferences Panel. Please 
refer to the previous sections of the manual, to learn what the 
controls do.

It is important to note, that the defaults are set to 
23.98 as the frame rate, and 1080p for the size. 
Change each to use “auto.” Once done, click on 
OK. This saves the settings inside Compressor. You 
can now use this encoder to export DPX frames.
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Qmaster Setup for Compressor
Qmaster is Apples render queuing system. With it, you can harness a group of computers 
together, to work on a set of jobs. Ideally, you can use any of these additional computers to 
work on tasks that you need done, without tying up your machine. A typical job might be 
converting a sequence of DPX frames into a ProRes 422 movie.

Before you can use Compressor and Qmaster with the Cineon/DPX Toolkit, you will need to 
make some changes to your Compressor setup. First, here is an explanation of what some 
pitfalls can be:

Problem: Rendering a QuickTime movie on a Qmaster node fails. The movie has one or two 
different frames that are repeated.

Fix: Go to the “Compressor” menu and select 
“Preferences.” Once the panel has opened, look for 
the “Cluster Options” popup menu and select “Never 
copy source to cluster”.

This is important, as Qmaster was never designed to 
work with image sequences as source frames. Qmaster doesn’t understand how to copy movies 
that are composed of several files. This is usually the cause of rendered QuickTime movies that 
have repeating frames. In order for Qmaster to work with the footage, the volume that holds 
the source frames must be mounted on each Cluster Node. When the render job is submitted, 
each of the Cluster Nodes will see the frames as “locally available.” So the copy step isn’t 
required.

Problem: Exporting DPX frames from a Single Movie, using several systems, fails. (ie: have 
several machine export the same movie)

Fix: There isn’t any way to use several machines to work on a single movie at this time. You will 
need to send a single movie to a single machine, when exporting a QuickTime movie to a DPX 
sequence. We hope to have this addressed in future updates.
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Spotlight Plugins and Get Info
Cineon and DPX files can be indexed and 
searched by Spotlight. Simply typing in a 
relevant bit of text, into the Spotlight text 
field, will search all of the Cineon or DPX 
metadata on your system, and locate the 
associated frames. For instance, if you have 
the shot name saved inside your Cineon or 
DPX sequences, you can search for them by 
name. The screen grab, below, illustrates how 
this works. 

The DPX frames shown, have the Slate Info 
field populated with the shot name. Simply 
searching for the shot name brings up a list 
of frames that belong to that shot. Other 
criteria can be searched for, as well, including 
image resolution, Colorimetric type (LOG or 
LIN image), Time Code, etc.

Get Info:
Get Info (Command - I) in the Finder allows you to view the details of 
any Cineon or DPX file. Much like the Spotlight window, you can get 
info about a single file, that you happen to click on. 

The Get Info panel will display DPX specific information in the Cineon 
or DPX files. Click on any Cineon or DPX frame on your system and 
perform a “Get Info.”
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3DLUT Support Appendix
Note: There is a large number of different file formats (and their variations) out there. It is hard 
to choose which ones to support. If the format that you want to use isn’t supported, please 
contact us via the support section of the support.gluetools.com website. We would really like to 
know what you want to see supported.

3DLUT files
3DLUT files are supported two different ways. You can “globally” use a 3DLUT file for each and 
every Cineon or DPX sequence, or, with Final Cut Pro (and Motion) you can use a 3DLUT on a 
clip by clip basis.

Currently, the Cineon/DPX Toolkit supports two different LUT formats. Thomson/Grass Valley’s 
LUTher text file 3D LUT and Pandora’s/Apple’s Color 3D LUT file format. We are expecting to 
add the Autodesk “3DL” very shortly. 

Additional files may be supported in the future. If there is a format that you would like to see 
supported, please let us know!
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Troubleshooting Other Applications - After Effects, Smoke, Combustion
Many other platforms and applications can read DPX frames. The universality of DPX is what 
makes it easy to move uncompressed imagery around the industry. However, not all 
applications can read all variations of the SMPTE DPX specification. Specifically, Adobe After 
Effects, and Discreet’s (now Autodesk) Flame and Smoke can not read all versions of DPX files. 
Unfortunately this is true for some frames exported by the Glue Tools Cineon/DPX package.

In order to export frames that are compatible with these packages, force the imagery to be 
exported as “Big Endian.” You do this by opening the System Preferences->CineonDPX pane. 
Click on the “Codec” tab, and change the “Endian” Pop-up menu.
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Technical Support
Support for these tools can be obtained by posting support question at 
http://support.gluetools.com.

Online support also includes an Knowledgebase section. The Knowledgebase is a great place to 
to find commonly asked questions questions.

Telephone Support is available Monday to Friday, 9AM to 5PM PST/PDT.

Glue Tools LLC! Cineon/DPX Toolkit for MacOSX - v4.0

29

http://support.gluetools.com
http://support.gluetools.com

