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System Requirements
Minimum Hardware and Software Configuration
• Intel Macintosh
• Mac OS X 10.5.8
• QuickTime 7.6.6 (or later)
• 1920 x 1200 display
• Final Cut Studio 3
Recommended Hardware and Software Configuration (Playback)
• 12-Core Intel Mac Pro System
• Mac OS X 10.6.4 (or later)
• QuickTime 7.6.6 (or later)
• 4 Gigabytes of RAM or more
• Dual 1920 x 1200 displays
• High Speed storage, such as a SAS RAID, SATA2 RAID, Fiber-channel RAID or SAN.
• Final Cut Studio 3

Playback Requirements
ARRI’s ARRIRAW file format is designed to contain raw bayer sensor data from their Alexa, D-21 
and D-21HD digital cinema camera models. Like DPX sequences, the ARRIRAW format is 
designed to have a single frame per file. Each file is about 5 Megabytes per file. ARRIRAW 
sequences will likely require machines with better than average performance. It is suggested 
that the most recent 12-Core Mac Pros be used in order to achieve full Playback.

Playback of ARRIRAW footage will also require systems with high speed storage. At minimum, a 
RAIDed SATA storage array, SAS Storage array, or 4G/b based directly attached Fiber-Channel 
storage is suggested.

Glue Tools LLC! ARRIRAW Toolkit for Final Cut Studio v1.5

5



Overview
QuickTime Components
The ARRIRAW QuickTime Component will perform all of the importing, playback, de-bayer, and 
color correction functions to the movie. All applications that use Apple’s QuickTime libraries 
can access all aspects of the ARRIRAW image sequences. Applications ranging from Final Cut 
Pro right down to iMovie, can import and play these files without any sort of conversion or 
preprocessing steps.

There are no direct “controls” or programs to launch in order to use these components. Your 
QuickTime enabled application will simply “recognize” ARRIRAW sequences as another movie 
format that can be used. Your Macintosh will also be “aware” of the files, much the same way 
QuickTime movies are already available to the system.

System Preferences
The Glue Tools ARRIRAW preference pane is where you pre-set all of the settings that the 
components use. These settings include White Balance modes, De-bayer Algorithms, Exposure 
Index, Color Space, and White Point conversions. The panel also handles licensing information, 
Time Code support and more.

Final Cut Pro Plugins
With a purchased license, you will see new Final Cut Pro Import plugins in the File->Import 
menu. Included is “Glue Tools ARRI ProRes Import.” “Glue Tools ARRIRAW Import.” You will 
select either menu item to import ARRIRAW or LogC ProRes footage right into Final Cut Pro. You 
can also “shift select” folders containing a number of sequences to batch load a number 
sequences at once.

Also included is an FxPlug Filter so that you can dynamically (and non-destructively) adjust the 
color processing of the footage. As this is a standard Final Cut Pro FxPlug Filter, you can make 
adjustments on a clip by clip basis.

Spotlight Plugins
The Spotlight Plugins enable your system to see inside the ARRIRAW header. The Finder can 
extract specific information from the ARRIRAW “.ari” files when it does a “Get Info.” You can 
search for camera models, encoding characteristics, or even “shot notes” from the user 
modifiable “description field” from the Finder’s Spotlight panel. Simple shell scripts can also 
take advantage of the spotlight services and sift through frames for specific data.
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Installation and Demo Mode
Installation
Installation is as simple as double-clicking on the installer package, then selecting the hard 
disk that you want to install the software onto. Once installed, you will need to reboot your 
machine.

Note: If the system does not contain the proper version of Final Cut Studio, various parts of the 
ARRIRAW Package will not install. If after the installation, parts of this product do not show up, 
please double-check that you meet the  minimum requirements.

IMPORTANT - Demo Mode

By default, the software needs to placed into “Demo Mode”. If the demo mode is not activated, 
the software will not work. To activate the “Demo Mode”, open your Mac’s System Preferences. 
Look for the “ARRIRAW” Preference Pane. You should see an Info tab alone the top edge of the 
window. Click on it to get to the licensing section. Near the bottom, you will see the “Activate” 
and “Demo” button. Click on the “Demo” button to get a 7 day temporary license.

If no license is purchased, the ARRIRAW Images with drawn or exported with a large colored bar 
through the center of the image. The LogC Filter for LogC ProRes movies will also be drawn with 
a blue bar through the image. Once a license has been purchased, the time limit will be 
removed and all of the imagery will be rendered properly. 
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Licensing
License Activation
Licensing must be done while connected to the Internet. If you do not have an internet 
connection, you will not be able to activate the license. In many cases any type of network 
connection will get you up and running. Once activated, you will not be required to have a 
network connection, unless you want to move the license to another Macintosh.

To activate the license, you will need the Registration Code that was emailed to you. Open the 
System Preferences, and click on the ARRIRAW preference pane. Click on the “Activate” button 
which will then open the panel for the Registration Code. You can then cut and paste the 
encryption string from the email, into the “Activation Code:” field. Once you click on the 
“Activate” button, the software will verify the license with our server and create a permanent 
license for you. Until you decide to move the license, this will be the only time that the internet 
is used for licensing.

Revoking/De-authorizing a License

If you need to move a license to another machine, you can use the same license code to 
“Revoke” the license from the machine that you are on. Just as you had done with the license 
activation, Open the System Preferences->ARRIRAW preference pane. Open the Info tab and 
click on the “Revoke” button. You can now cut and paste the same activation code into the 
“Acivation Code:” field. Then click on the “Revoke” button. Once deactivated, the license will be 
free so that another machine can be used.

License Troubleshooting
If you encounter a problem with your licensing because of network issues, consult with your IT 
Dept. The most common cause of problems is a blocked internet port or a Firewall Proxy 
system. The licensing can be modified to use one of 2 internet ports: Port 80, which is the 
default port or Port 44333 (an alternate port). Select either of these ports to try to perform a 
license authorization. 

If the problem persists, email support@gluetools.com for further assistance.
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Quick Start Guide
Importing an ARRIRAW Image Sequence - The Correct Way
Just about everyone has used QuickTime to load a range of individual frames and convert them 
into a single movie. Normally, this is done by using  an “Import Image Sequence” command 
inside the QuickTime application.  Typically these images are a series of TIFF files or JPEGs with 
sequential frame numbers. Under normal circumstances, this works just fine. The sequences of 
picture files are just what they are . . . a series of still images with no other useful data.

However, this is not true for ARRIRAW “.ari” files. The ARRIRAW sequences are in fact a single 
movie. The difference between a ARRIRAW “Movie” and a regular “.mov” file, is that each frame 
is a separate file. A “.mov” file has all of its frames inside a single file. A feature that makes 
ARRIRAW frames different from other Image formats, is that the ARRIRAW frames contain 
“metadata” that is specific to the film and HD broadcast industry. Time Code, slate information, 
and other information etc, is stored in the image header.

So, what does this ultimately mean? It means that to properly load an ARRIRAW sequence into 
you favorite application, use the “Open->File...” menu, and select A SINGLE frame from your 
sequence. Then click on “Load” or “Ok.” The entire movie will load shortly. DO NOT use “Import 
Image Sequence” to load the frames.

Glue Tools has custom technology to treat these image types as a “virtual movie file” rather 
than a set of individual image files.  This means that all of the frames in the sequence are really 
just a single “Movie.” It also means that when you are selecting any one ARRIRAW “.ari” file from 
a sequence, it is the same as opening all of the frames in the sequence. 

Because of this, you no longer need to shift-select all of the frames to load them. As a result of 
the way this works, you are able to load metadata, Time Code and other information that would 
normally be associated with a QuickTime movie.

But what about the “Import Image Sequence” menu command?

Using this method of loading frames, you loose the ability to import metadata, Time Code, etc. 
You also loose the Playback ability, too. When importing ARRIRAW frames as an Image 
Sequence, QuickTime believes the sequence is just a bunch of still images, not a series of 
frames in a movie.

Importing a Sequence into QuickTime Player
One of the most basic ways of using the ARRIRAW Toolkit is to take one of the frames from your 
sequence and drag and drop it over top of the QuickTime icon. Doing this will open the entire 
sequence inside QuickTime Player.

Exporting a New Movie from QuickTime Player
For the ease of portability with other users, you can quickly and easily convert an ARRIRAW 
Movie to any other QuickTime Movie format. You can do this by opening the ARRIRAW sequence 
using QuickTime Player, and then selecting the “File->Export....” Select your codec, location 
and filename as you would with any other movie, and start the export. It is that easy.

Importing a Sequence into Final Cut Pro
Final Cut Pro has a specially built interface to work with the ARRIRAW “.ari” files. To import the 
footage, select the “File->Import->Glue Tools ARRIRAW Import...”. Locate a “.ari” file, and click 
“Ok.” Your sequence will now appear in the browser, complete with the file’s metadata.

That’s it!
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ARRIRAW Reference
This package consists of a number of parts that make up the whole: the ARRIRAW QuickTime 
component, a System Preferences Pane, and a Spotlight Plugin. Each of these pieces are briefly 
described in turn.

Preference Pane
The Glue Tools ARRIRAW Preferences Pane is where you can change the Global 
settings used by the ARRIRAW QuickTime Component. If you want of change 
the Exposure settings, change the Color Space from Video to LogC, or alter the 
Time Code settings, you can do it with the System Preferences Panel.

Let’s begin by opening the System Preferences, and clicking on the Glue Tools 
ARRIRAW preference icon.

Render & Playback Tab
You will notice that the Presets Tab is divided into two sections: "Image & Playback Options" and 
"SMPTE Time Code Options."

ARRIRAW Rendering Options:

Image Debayer Quality
This pop-up menu is used to select the type of de-bayer algorithm to be used to interpolate 
the sensor data. Different de-bayer modes will concentrate on a specific “look” when creating 
an image. Some modes will simply “average” the sensor pixel values to estimate the RGB values. 
Other de-bayer algorithms are much more elaborate, carefully examining each pixel to best 
handle gradients, hard edges, and color changes. Naturally, the more elaborate the de-bayer 
algorithm, the more processing speed is needed by the software. On slower machines, de-bayer 
algorithms such as “GT Hybrid A” will significantly impact playback. However, this type of 
algorithm is ideal when exporting to another QuickTime movie format.

De-bayer performance is sorted by their order in the menu. The top mode menu item, “Raw 
Sensor Data Mode” is the fastest, as no de-bayer algorithm is being applied. “Gray Scale,” 
“Nearest Neighbor,” “Bilinear Interpolation” are the next fastest modes. The slowest yet most 
accurate is “GT Hybrid A” which is at the bottom of the menu.
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Aspect Ratio
This pop-up menu allows you to choose 
between a number of different Aspect Ratios, 
that the image will be displayed as. When 
loading the Images, you can select the 2.0 
Aspect Ratio, and the images will be 
automatically re-sized, without any data loss. 

The example image here, illustrates the 
concept. The example frame is an Anamorphic 
Image. On the left is an uncorrected 1.778 
anamorphic image, while the right image has 
been corrected for 2.35.

Final Cut Studio: Color Override
This checkbox will cause any ARRIRAW file without using its color information. This command is 
used in conjunction with the ARRIRAW Color FxPlug filter, to allow you to modify the way the 
ARRIRAW Sequence is rendered inside Final Cut Pro.

Final Cut Studio: Generate Color Filters on Import
This checkbox causes the Import->Glue Tools ARRIRAW Import plugin to automatically create 
an FxPlug Filter for each ARRIRAW sequence that is imported. As each sequence is imported, 
the filter will have its settings adjusted to match what is inside the ARRIRAW’s header.

Playback & Time Code Options:

Playback Frame Rate
This lets you override the frame rate found inside the ARRIRAW files, and forces your 
Application to use the value that you choose.

TC Frame Rate
This lets you override the time scale that the Time Code track uses. This can be different from 
the playback Frame Rate. This control, combined with the playback Frame Rate pop-up can let 
you simulate a Tele-cine operation. i.e.: selecting a 24 FPS for the playback Frame Rate and a 
25 (or 29.97) for the Time Code.

Override Source Time Code
When enabled, you can alter any of the Time Code settings. Many of the settings are disabled 
until you enable this check box. When it is disabled, Time Code is used from the Time Code 
metadata within the “.ari” file.

Start Time
When enabled, you can enter in your own Time of Day start time. You can click on the “Reset 
Time Code” button to bring it back to 00:00:00:00

TC/Reel Name
The "TC Source Labeling" Pop-up menu determines how QuickTime identifies the Time Code 
track. You can type in your own text into this box, or use one of a number preset options in the 
menu.

“User Defined” allows you to type your own description into the text field below. When selected, 
you are able to type in up to 12 characters, which will be used as the Reel Name. You can use 
either the “Root” file name from the first frame, or you can use the parent directory that the 
frames are stored in, as the reel name. 
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ARRIRAW Color Tab
This Tab is divided to two parts: Alexa ARRIRAW Color Settings and D-21 ARRIRAW Color 
Settings. Each of these section independently set the Global settings for each camera type. For 
instance, a setting in the D-21 section will not affect the Alexa settings. 

Alexa ARRIRAW Color Settings:

Color Space
This pop-up menu lets you choose between the Rec 709, DCI P3 and LogC colorspaces. Again, 
this affects all Alexa ARRIRAW sequences. This settings is specific to the Alexa and is not 
available on the D-21. 

Exposure Index
This pop-up menu lets you choose from a range of Exposure Index settings. By default, the 
setting that has been placed into the “.ari” file’s header by the camera, is used. You can choose 
to override this, but keep in mind that this setting is Global for all Alexa ARRIRAW sequences.

White Point & White Point Slider
This pop-up menu and Slider lets you choose between different White Points, should the 
information not be available in the ARRIRAW header. By default, the setting that has been 
placed into the “.ari” file’s header by the camera, is used.  This affects all Alexa ARRIRAW 
sequences. This settings is specific to the Alexa and is not available on the D-21.

v1.0 ARRIRAW Color Settings (Legacy/D-21):

Exposure Index
This pop-up menu lets you choose from a range of Exposure Index settings. By default, the 
setting that has been placed into the “.ari” file’s header by the camera, is used. You can choose 
to override this, but keep in mind that this setting is Global for all D-21 ARRIRAW sequences.

White Point
This pop-up menu lets you choose between a range of White Point settings. This particular 
setting is specific to the D-21 camera is not available for Alexa footage. Again, this affects all 
D-21 ARRIRAW sequences.
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Metadata (Version 1 Headers Only)
So far, at the time of this writing, only Codex Digital offers the ability to imbed the appropriate 
metadata into the ARRIRAW file. To enable metadata access, you can select either “Generic” or 
Codex Digital in the metadata popup menu. If Generic is selected, the appropriate fields in the 
“.ari” file will be embedded into you Final Cut Pro Project, without any pre-processing. If your 
frames came from a Codex Digital recorder, you can select “Codex Digital”, and have the 
metadata processed to fit in the FCP XML structure. This allows for significantly better data 
tracking in your project.

Info Tab / Licensing

In the "Info" tab, you can click on links to the Glue Tools website, as well as direct links to the 
Support/FAQ pages, and the Registration pages. If you wish to purchase a license for the 
ARRIRAW Toolkit Package, visit www.gluetools.com, go to the "purchase" page and follow the 
instructions there.
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Final Cut Studio Reference
Final Cut Pro “ARRIRAW Import” and “ARRI ProRes Import” Plugins
Final Cut Pro users can now import ARRIRAW and LogC ProRes footage with dedicated Import 
Panels. Each panel can be easily be accessed by selecting the “File->Import...” menu.

The ARRIRAW Import panel for Final Cut Pro provides most of the same controls that the 
ARRIRAW Preference Pane does. However, the panel adds the ability to extract metadata right 
out of the ARRIRAW file, and place the information right into your FCP project. Shot notes, color 
information, and other information is extracted and available in the XML that FCP generates.

The ARRI ProRes Import panel is similar to the ARRIRAW import panel, but is specifically built to 
batch import LogC ProRes movies and add the appropriate ARRI Camera Filter plugin. 

Final Cut Pro Sequence Presets
Final Cut Pro provides a set of “Sequence Presets” which allows you to quickly configure your 
system for different editing scenarios. Included with the package is a set of predefined 
Sequence Presets. These are generic presets for standard frame rates, and image sizes. As with 
the other Sequence Presets that Apple provides, you can duplicate and customize these to suit 
your needs.

Also included with these Sequence Presets, is a set of AJA Kona3 specific Sequence Presets. 
These presets allow you to preview your footage out though the Kona 3 hardware.

ARRI LogC Camera FxPlug Filter

Final Cut Studio provides developers with a plugin technology for manipulating your image. We 
have developed plugins to let you adjust your ARRIRAW and ProRes LogC footage.

The ARRI Camera Filter plugin is designed to interactively adjust the exposure and colorspace 
of your footage. You have two different types of media that you can correct. You can correct 
ARRIRAW or ProRes “LogC” files from the Alexa Camera files.

ARRIRAW Files
To get started, select Import->Glue Tools ARRIRAW Import... but before importing some “.ari” 
files, click on the “Render” tab and make sure that “Color Override” and “Generate Color Filters 
on Import” enabled.

Now, you can go ahead and import a clip. Once the ARRIRAW Sequence appears in the browser, 
double click on it. This will display the file in the Browser:Slug window. Along the top is a bunch 
of tabs. Click on the “Filter” tab. This will display the newly attached ARRI LogC Color FxPlugin. 
With this plugin, you can modify the color as you see fit.

When you imported the “.ari” sequence, the header of the first “.ari” was read as well. Using the 
settings from that file, the newly created ARRI LogC Color FxPlugin was preset with all of the 
needed settings. This will provide you with a starting point from which you can make 
adjustments.
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Drag your ARRIRAW clip onto the timeline and double click on it. Then select the “Filter” tab 
from the top of the Browser:Slug window. You will be presented with a list of sliders and pop-
up menus. A description of each control is provided below. The best way to learn what they do, 
is to try them out. As you make each adjustment, you can see its effect on the right side of the 
display.

A feature of these plugins is that you can duplicate the ARRIRAW clip on the timeline several 
times. If you had three copies of the same ARRRAW clip on the timeline, each of the three could 
have different FxPlug settings. Ideally suited when you are trying to make creative color 
decisions in your project.

ProRes LogC Media 
When the ARRI Camera Filter is applied to your LogC ProRes media, you can quickly preview the 
footage in Video mode, without rendering.

To get started, select Import->Glue Tools ARRI ProRes Import... but before importing MOV files,  
be sure to set some defaults. You can batch import several movies, and have each imported 
with the ARRI Camera Filter attached.

Once imported, you can drag a ProRes LogC clip onto the timeline and double click on it. Then 
select the “Filter” tab from the top of the Browser:Slug window. You will be presented with a list 
of sliders and pop-up menus. A description of each control is provided below. The best way to 
learn what they do, is to try them out. As you make each adjustment, you can see its effect on 
the right side of the display.

ARRI LogC Camera Filter Settings 
This filter is applied to either LogC ProRes or ARRIRAW footage. It works with v2.0 or v3.0 based 
media files. 

Color Space
- This pop-up menu lets you select the color space that the image will be displayed in. You can 
choose between Rec 709, DCI P3 or Film Look LogC color.

Exposure Index
- This pop-up menu allows you to change the Desired Exposure Index of the footage. This will 
allow you to change the ASA as needed. 
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Recorded Exposure Index
- This pop-up menu allows you to pre-determine what the Exposure Index is of the footage. If 
you are using ARRIRAW or LogC ProRes footage from a v3.0 or later Alexa, this will be 
automatically set, when imported. Files created with cameras using older firmware versions, will 
need to be set manually.

Color Processing Version
- This pop-up menu lets you select the color processing version of your media. Alexa Cameras 
that use v3.0 will not need to be adjusted. Cameras using earlier firmware versions will need to 
have this manually set to version 1 or 2. If this setting isn’t set according to the proper version, 
the resulting image will not look right.

These settings are stored inside the Final Cut Pro project file. Nothing that you adjust here will 
affect the ARRIRAW file. The changes are non-destructive.
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Qmaster Setup for Compressor 3
Qmaster is Apples render queuing system. With it, you can harness a group of computers 
together, to work on a set of jobs. Ideally, you can use any of these additional computers to 
work on tasks that you need done, without tying up your machine. A typical job might be 
converting a sequence of ARRIRAW frames into a ProRes movie.

Before you can use Compressor and Qmaster with the ARRIRAW Toolkit, you will need to make 
some changes to your Compressor setup.

Problem: Rendering a QuickTime movie on a Qmaster node fails. The movie has one or two 
different frames that are repeated.

Fix: Go to the “Compressor” menu and select 
“Preferences.” Once the panel has opened, look for 
the “Cluster Options” popup menu, and select “Never 
copy source to cluster.”

This is important, as Qmaster was never designed to 
work with image sequences as source frames. Qmaster doesn’t understand how to copy movies 
that are composed of several files. This is usually the cause of rendered QuickTime movies that 
have repeating frames. In order for Qmaster to work with the footage, the volume that holds 
the source frames must be mounted on each Cluster Node. When the render job is submitted, 
each of the Cluster Nodes will see the frames as “locally available.” So the copy step isn’t 
required.
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MacOSX Reference 
Spotlight
ARRIRAW files can be indexed and searched by Spotlight. Simply typing in a relevant bit of text, 
into the Spotlight text field, will search all of the ARRIRAW “.ari” files’ metadata on your system. 

Macintosh Finder / Get Info
Get Info (Command - I) in the Finder allows you to view the details of any ARRIRAW file, as well. 
Much like the Spotlight window, you can get info about a single file, that you happen to click 
on. 

The Get Info panel will display ARRIRAW specific information in the header of the selected files. 
This is an excellent diagnostic tool when working with the ARRIRAW file format.

You can view the following types of information, if available:
Image Size
Bit Depth
Packing Type
Frame Rate
Time Code
Frame Number
Take Number
Codec
Device Name
Project Info
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Terminology
Here is some terminology that you may not be familiar with.

Bayer Pattern Imagery
Traditionally, you would assume that each pixel is a 
combination of Red, Green and Blue channels to make each 
pixel. With single sensor digital cameras, each pixel is in-fact a 
single color. The “Bayer Pattern” was invented by Dr. Bryce E. 
Bayer at Kodak, who came up with the "bayer pattern" color 
filter array. He came up with the way each color is arranged on 
the camera sensor (see attached graphic). Each line on the 
sensor contains alternating pixels of Green and Red, and the 
next line below alternates Blue and Green. By using a “de-
bayer” algorithm, a proper RGB image can be reconstructed. 
Different types of de-bayer algorithms will reproduce different levels of image quality. 
Typically, “fast” de-bayer algorithms are of a poor quality. “Slow” algorithms are typically much 
better. (Image courtesy of Wikipedia).

Here are examples of some de-bayer 
algorithms. On the left, is a “Raw” Bayer 
Pattern. In the centre is a “fast” Nearest-
Neighbour de-bayer pattern and on the 
right a “better” Pixel Grouping de-bayer 
pattern. As you can see, there will be a a 
substantial quality difference, depending 
upon the de-bayer algorithm you choose. At this time, GT Hybrid A is our best quality de-bayer 
algorithm. As these de-bayer algorithms get better, you can expect to see improvements as 
new versions are released.
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Technical Support

Support for these tools can be obtained by posting questions in the User Forum at 
www.gluetools.com.

Online support also includes a FAQ section. The User Forum is a great place to ask your own 
questions, if you can’t find the answers. The User forum is located at:
http://www.gluetools.com/FUDforum2/index.php

Emails for help can also be sent to support@gluetools.com. Detailed consulting for specific 
features and improvements is also available on a case by case basis. Please contact us with your 
specific needs.

Support is available Monday - Friday, 9AM to 5PM PST/PDT.
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